Funktionen

Definitionen
Funktion: Eine in Excel eingebaute vordefinierte Formel. Sie wird für bestimmte Zwecke genutzt.
Zellbereich: Eine Gruppe von Zellen im Arbeitsblatt. Man unterscheidet zwei Arten: zusammenhängende und nicht zusammenhängende Zellbereiche. Ein Zellbereich ist zusammenhängend, wenn die Zellen nebeneinander liegen. Tun sie es nicht, ist der Zellbereich nicht zusammenhängend.

Die SUMME()-Funktion
Im letzten Kapitel haben wir ja schon ein wenig die SUMME()-Funktion vorgestellt. Sie hat den Sinn und Zweck, lange Formeln zu vermeiden. Es wäre sehr umständlich zu schreiben:
=B3+B4+B5+C3+C4+C5+B10
Wir haben hier einen Zellbereich: B3 bis C5 und die Einzelzelle B10. Einen Zellbereich stellt man in Excel so dar, dass, wenn es sich um einen zusammenhängenden handelt, er die erste Zelle oben links beinhaltet, dann einen Doppelpunkt und dann die letzte Zelle unten rechts. Ist eine Zelle außerhalb dieses Bereiches, so wird sie durch ein Semikolon (;) abgetrennt. Also wäre der Zellbereich von oben folgender:
B3:C5;B10
Diesen Bereich setzen wir jetzt in der SUMME()-Funktion zwischen die Klammern, so dass es dann so aussieht:
=SUMME(B3:C5;B10)
Jetzt kannst du im Bereich B3:C5;B10 etwas ändern. Das Ergebnis wird automatisch neu berechnet.

SUMME()-Funktion
Man kann sehen, dass zur Vereinfachung außerdem die Bereiche in der Tabelle nochmal farblich gekennzeichnet werden. Wenn du es etwas einfacher haben willst, gibst du die Formel bis zur ersten Klammer ein und markierst dann den Bereich B3:C5 mit der Maus, indem du die linke Maustaste gedrückt hälst und die erste Zeile anklickst und dann bis zur Letzten ziehst. Die einzelne Zelle B10 bekommst du, wenn du die [Strg]-Taste gedrückt hälst und die Zelle dann mit der Maus anklickst. Dann kannst du die Klammer schließen, falls das nicht automatisch geschehen ist.

Die Funktion MITTELWERT()
Für die Referenz (also der Befehlsaufbau) der Funktion MITTELWERT() gilt das Gleiche wie für die SUMME()-Funktion. In die Klammer wird der zu berechnende Bereich eingetragen. Wir arbeiten diesmal sogar mit zwei Zellbereichen: A2 bis C12 und D25 bis F30. Wir haben also den Gesamtbereich A2:C12;D25:F30. Diesen Bereich tragen wir nun in die Funktion ein, also wiefolgt:
=MITTELWERT(A2:C12;D25:F30)
Die MITTELWERT()-Funktion berechnet - wie der Name schon sagt - den Mittelwert von den Zahlen im angegebenen Bereich. So kann man zum Beispiel seine Zeugnisnote berechnen:
MITTELWERT()-Funktion
In Zelle C9 steht als Formel:
=MITTELWERT(C4:C7)
Wir haben also die Zeugnisnote ohne die Formel =(C4+C5+C6+C7)/4 mit einer Funktion errechnet. Auch hier werden die Argumente wieder hervorgehoben, wenn man die Zelle C9 gerade bearbeitet.

Mehrere Funktionen in einer Formel
Es ist natürlich auch möglich, nicht nur eine Funktion pro Formel einzubauen, sondern soviele man will. Will man z.B. die Summe von einem Zellbereich durch den Mittelwert des selben Bereichs haben, kann man schreiben:
=SUMME(A2:C12)/MITTELWERT(A2:C12)
In Excel kann man sogar soweit gehen, eine Funktion in einer Funktion einzubauen. So könnte man z.B. schreiben:
=SUMME(A2:C12;MITTELWERT(A2:C12))
Diese Berechnungen sind aber oft nicht sehr sinnvoll.

Die ANZAHL()-Funktion und die ANZAHL2()-Funktion
Excel bietet die Möglichkeit, in einem Zellbereich die Anzahl aller vorkommenden Zahlen und Ziffern ausgeben zu lassen. Sinnvollerweise hat diese Funktion den Namen ANZAHL(). Will man aber die Anzahl aller Zellen, in denen etwas steht (Text, Zahlen, Daten, etc.), gibt es eine Funktion mit dem sehr einfallsreichen Namen ANZAHL2(). Beide Funktionen sind durchaus gebrauchbar. Beide brauchen wieder in den Klammern den Zellbereich. Er wird genauso wie in den vorangegangenen Funktionen gebildet.
Wenn man die Funktion MITTELWERT() nicht mag, kann man übrigens auch schreiben:
=SUMME(A2:C12)/ANZAHL(A2:C12)
Das ist dann aber etwas umständlich und wird in einer Prüfung nicht erwartet.
ANZAHL()-Funktion

Die WENN()-Funktion
Excel bietet die Möglichkeit einer Wenn-Abfrage. Wir können uns das mit einem deutschen Satz so vorstellen: WENN heute die Sonne scheint, DANN gehe ich ins Freibad, SONST bleibe ich zuhause. Wir haben also eine Wenn-Dann-Sonst - Abfrage. Die drei Werte (WENN-Wert, DANN-Wert, SONST-Wert) werden mit einem Semikolon abgetrennt. Also wäre unser Satz etwa: Sonne scheint;Freibad gehen;Zuhause bleiben
Jetzt muss man das auf Excel-Format verarbeiten. In Zelle A1 soll eine Zahl stehen: 0 für schönes Wetter und 1 für schlechtes Wetter. In Zelle A2 soll stehen, ob wir ins Freibad gehen oder es lieber lassen. Die Formel in A2 lautet also:
=WENN(A1=0;"Geh ins Freibad";"Bleib zu Hause")
Wie du sehen kannst, haben wir einen Vergleichsoperator zwischen dem A1 und der 0: das Gleichheitszeichen. Hier die Auflistung der Standard-Operatoren zum Vergleichen:
= Gleich
< Kleiner als
<= Kleiner oder gleich
>= Größer oder gleich
> Größer als
<> Ungleich
Im Beispiel oben ergibt sich jetzt ein kleines Problem: Wird in A1 z.B. 2 eingetragen, so sagt Excel, dass du zuhause bleiben solltest, obwohl 2 nicht weiter definiert ist (weder schönes noch schlechtes Wetter). Daher können wir mehrere WENN()-Funktionen verschachteln. Das sieht dann etwa so aus:
=WENN(A1=0;"Geh ins Freibad";WENN(A1=1;"Bleib zu Hause";"Kein gültiger Wert eingegeben!"))
Zu beachten: Am Ende sind zwei Klammern (es werden ja auch zwei WENN()-Funktionen geschlossen). Innerhalb der Funktion kann man im DANN- oder SONST-Wert auch noch Formeln einfügen. Dazu nutzen wir das kaufmännische UND-Zeichen (&). Dabei wird der Text unterbrochen, indem wir die Anführungszeichen schließen und evtl. am Ende wieder öffnen. Eine Formel hat am Anfang und am Ende das &-Zeichen, es sei denn, darauf folgt nichts mehr bzw. vorher steht nichts. . Das sieht dann also so aus:
=WENN(A1=0;"8+15="&8+15&"!!!";"15-8="&15-8)
Das &-Zeichen verbindet also Text mit Rechnungen. Ist kein Text vorhanden, wird das &-Zeichen nicht benötigt.

MIN() und MAX()
Wenn man eine größere Anzahl an Ziffern und Zahlen hat, kann man mit den Funktionen MIN() und MAX() die jeweils kleinste bzw. größte herausfiltern. In die Klammern gibt man den Bereich ein, in dem die Zahlen stehen.
MIN()- und MAX()-Funktion

Druckversion Blog
Impressum
Kontakt

Letzte Änderung: 28.10.2016 01:21 Uhr
URL: https://www.lern-online.net/informatik/software/anwendungen/tabellenkalkulation/lektion07.php